UPDATES BEST OF FILTER PASSWORT
Wolcen - Lords of MayhemTransport Fever 2MechWarrior 5 - MercenariesDarksiders Genesis

Kleines Preview von V2
Hier ist bereits ein Teil von V2 (Detailseite). Alle anderen Bereiche werden zeitnah nachgereicht und laufen noch auf V1.
Feedback via E-Mail ist erwünscht.

Planet Explorers

Abenteuer, Action, RPG, Simulation, Indie

2014

63 / 7.2

Cover & Fakten
Planet Explorers
Spielbeschreibung
Mit Planet Explorers hat ein weiteres innovatives Projekt auf Kickstarter sein Spendenziel erreicht. Das Sandbox-Rollenspiel mit Voxelgrafik erinnert mit seiner offenen Welt und der starken Einbindung der Community an Minecraft. In der futuristischen und extrem weitläufigen Welt könnt ihr euch frei austoben und Waffen und Vehikel im Editor selbst gestalten. Im neuen Showcase-Video zeigt euch einer der Entwickler einige der selbst gebauten Fahrzeuge und Waffen, die Spieler in der frei verfügbaren Alpha-Version von Planet Explorers bereits erstellt haben.
Spezifische Informationen zum Release
ElAmigos release, game is already cracked after installation (crack by Codex). Updated to version 1.1.3 64bit (30.03.2018).
Planet.Explorers-ElAmigos
6.83 GB
Premium
Freeuserfreundlich
Alle Mirror (Dateien) sind untereinander kompatibel. Unsere Releases müssen nur einmal entpackt werden.
Der Download via zippyshare.com ist aus Deutschland nicht möglich. Dafür bitte einen VPN oder Proxy nutzen.
Minimale Systemanforderungen
Empfohlene Systemanforderungen
Betriebssystem: Win 7 64bit
Prozessor: i3+
Arbeitsspeicher: 6 GB RAM
Grafik: GTX 460+ HD 5770+
DirectX: Version 10
Netzwerk: Breitband-Internetverbindung
Speicherplatz: 6 GB verfügbarer Speicherplatz
Zusätzliche Anmerkungen: Must have OpenCL compatible CPU or GPU (DX10.1) 32bit can run, but will experience some memory crashes on higher qualities

Betriebssystem: Win 7 + 64bit
Prozessor: i5+
Arbeitsspeicher: 8 GB RAM
Grafik: GTX 760+ HD7000+
DirectX: Version 11
Netzwerk: Breitband-Internetverbindung
Speicherplatz: 8 GB verfügbarer Speicherplatz
Zusätzliche Anmerkungen: Must have OpenCL compatible CPU or GPU (DX10.1)